Windows 10 Start menu missing, apps not working

Nov 10
2015

Today, I had a severe problem on a users Windows 10 Tablet (Dell Venue Pro 11).

This machine suddently stopped showing the start menu, and no app worked. Even the Notify screen was unable to start.

I have tried a lot of things, until I looked in the Event Viewer (Applications), and there I found a lot of errors like this one:

svchost (2356) TILEREPOSITORYS-1-5-21-1151363738-2262017715-1772219638-1001: Non è stato possibile leggere l’intervallo di log dal file “C:\Users\Michele\AppData\Local\TileDataLayer\Database\EDB.log” all’offset 1056768 (0x0000000000102000) per 4096 (0x00001000) byte a causa di una mancata corrispondenza del checksum dell’intervallo. Checksum previsto: 3595365752422194926 (0x31e54e1a4ebadeee). Checksum effettivo: 3595365752422194926 (0x31e54e1a4ebadeee). L’operazione di lettura non verrà effettuata con errore -501 (0xfffffe0b). Se tale condizione persiste, ripristinare il file di log da un backup precedente.

To solve, I have opened a Administrator command prompt, moved to the indicated folder and renamed all .log files to .loa.

After this, the start menu and the apps worked again.

Windows 10 Upgrade experiences

Aug 17
2015

On this page, I will give Windows 10 Upgrade experiences, from our company PCs and from the PCs of customers.

First of all, the Windows 10 upgrades seem to work very well, specially when coming from Windows 8.1. I have upgraded several of our own machines (Fujitsu Stylistic Q703, Acer Iconia Tab W700, Fujitsu Esprimo X923T, an old Fujitsu Lifebook C1410, Acer Veriton N4620G with an i3-2377 all from Windows 8.1, without any problem).
I have also not encountered any problems on my former development notebook, a Fujitsu Lifebook E8410 with Nvidia Graphics, upgraded from Windows 7 Pro.
I have also upgraded several custom machines successfully, most of the Fujitsu brand.

Unfortunately, I was not able to upgrade my current development machine, a Fujitsu Celsius H720. I have tried it two times, both times the upgrade from Windows 7 Pro failed with the message “Die für das System reservierte Partition konnte nicht aktualisiert werden” – traduced to “The reserved partition for the system could not be upgraded”. So I need to reinstall this machine from scratch.

One of my customers had an issue with a Dell Venue Pro 10″ with Windows 8.1 Pro: the machine hung in the reboot process for nearly an hour, and after a reboot the machine was returned to Windows 8.1. Addendum: I have cleaned up the HDD and installed Windows 10 successfully from an USB stick.

Another machine, a Fujitsu Esprimo P510, after the upgrade had lost the connection to the network – no IP address could be retrieved and also a static IP don’t helped. I downloaded the correct driver from Intels homepage, installed it, and the machine returned to work. It had an Intel I217-V chip.

A Acer Veriton with Intel Atom (D510) could not be upgraded – it hung in the reboot phase, and restored after than. I have tried the upgrade 3 times, without luck.

And a link for everyone interested in the upgrade: if you have more than one machine, build an USB stick for the upgrade with the Media Creation Tool:
https://www.microsoft.com/de-de/software-download/windows10

Windows 8 and Autodesk products, Installer issue

May 06
2014

On several Windows 8 machines there was a problem with Windows Installer that tried to execute the setup of AutoCad LT 2013 or DWG TrueView 2015.

Unfortunately, I could not find anything usable using my best troubleshooting friend: Google.

The solution for DWG TrueView

The solution came from looking in the event viewer under the Windows item, Applications. There was a error message like this one:

“Erkennung von Produkt “{5783F2D7-E028-0409-0100-0060B0CE6BBA}”, Feature “P” und Komponente “{370E1EB0-04EF-4807-8B56-4562457473B8}” fehlgeschlagen. Die Ressource “C:\Users\Lukas\AppData\Roaming\Autodesk\WebServices\Dummy.txt” ist nicht vorhanden.”

But the user “Lukas” was the one that installed DWG TrueView on this machine, and other users had not access to this file. The solution was simple: create a file “dummy.txt” in a directory accessibile to all users (I opted for “C:\ProgramData\Autodesk\Dummy.txt”, search the reference in the registry (was the entry “7D2F3875820E9040100000060BECB6AB” in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\0BE1E073FE407084B86554265447378B) and change the file location.

The solution for AutoCAD unfortunately was not so fast: in the eventviewer I could see that the installer tried to access a registry entry, precisely this one:

HKEY_CLASSES_ROOT(64)\TypeLib\{76B039F4-D977-4B80-8DEB-DCD74D6B337F}\1.0\0\win64\

Using RegEdit, I could not read that entry because it was not accessible. So I needed to change first the owner of the respective registry tree to “Administrators” and then add the right to read for all users – unfortunately several steps because this was to repeat for 3 different items, and the subitems became only visible after adjusting the properties of the owner item.

Addendum: DWG TrueView 2014 had the same issue as AutoCAD 2013.

It seems that the guys at AutoDesk have to adjust their installers….